rumesh38

Forum Replies Created

Viewing 15 posts - 1 through 15 (of 96 total)
  • Author
    Posts
  • in reply to: lost password link not working #20672

    rumesh38
    Moderator

    Hi there,

    I think you have WooCommerce Plugin installed. We have some conflict with the permalink of WooCommerce. To solve this issue, please change my account page to our my account page of WooCommerce. You can find that option under WooCommerce > Settings > Advanced > My Account.
    Hope this helps.

    Thanks & Regards,
    WPEverest Support Team.

    in reply to: I need to validate date_box #20671

    rumesh38
    Moderator

    Hi kyde,

    You can validate date field by adding the following code in the function.php file of your theme.

    function ur_validate_date( $single_form_field, $form_data, $filter_hook, $form_id ) {
    	$field_label = isset( $form_data->label ) ? $form_data->label : '';
    
    	if ( 'date_box_1558345242' === $single_form_field->general_setting->field_name ) { // Your field name from form builder.
    		if ( ! empty( $form_data->value ) ) {
    			$dob  = strtotime( $form_data->value );
    			$now  = strtotime( date( 'Y-m-d' ) );
    			$diff = ( $now - $dob ) / YEAR_IN_SECONDS;
    			if ( 18 > $diff ) {
    				add_filter(
    					$filter_hook,
    					function ( $msg ) use ( $field_label ) {
    						return __( $field_label . ' must be 18+.', 'user-registration' );
    					}
    				);
    			}
    		}
    	}
    }
    add_action( 'user_registration_validate_date', 'ur_validate_date', 10, 4 );
    

    If you have any query let us know.

    Thanks & Regards,
    WPEverest Support Team.

    in reply to: Only showing 20 invite codes while I created much more #20319

    rumesh38
    Moderator

    Hi there,

    Thank you for reporting the issue. We will fix it soon and let you know.

    Thanks & Regards,
    WPEverest Support Team.

    in reply to: Just Administrator can create users #20318

    rumesh38
    Moderator

    Hi there,

    The new update ( User Registration 1.6.1 ) has been shipped with this fix. Please update the plugin for the fix.

    Thanks & Regards,
    WPEverest Support Team.

    in reply to: Smart Tag {{user_pass}} does not work #20317

    rumesh38
    Moderator

    Hi there,

    You have been replied here.
    https://wordpress.org/support/topic/smart-tag-user_pass-does-not-work/

    Thanks & Regards,
    WPEverest Support Team.


    rumesh38
    Moderator

    Hi there,

    It might be due to the nonce error of WordPress. Your caching plugin is caching the nonce also. Due to which, an expired nonce is submitted on registration.
    Please try excluding the registration page from caching. As for WP Rocket Cache plugin, you can follow the following link.
    https://docs.wp-rocket.me/article/54-exclude-pages-from-the-cache

    Thanks & Regards,
    WPEverest Support Team.

    in reply to: Just Administrator can create users #20256

    rumesh38
    Moderator

    Hi there,

    The feature was added in our new patch update in order to prevent nonce error. But we are working to remove this feature in our next update.

    Thanks & Regards,
    WPEverest Support Team.


    rumesh38
    Moderator

    Hi Scotty,

    Sorry, our Invitation code field is required field by default. If it is added in the form it needs to be filled with valid code in order to register user.
    For your purpose, you can create a new registration form for your subscriber without an invitation code field.

    And you can only add one role to specific invitation code.

    Thanks & Regards,
    WPEverest Support Team.

    in reply to: Another form after user is registered and logged in? #20254

    rumesh38
    Moderator

    Hi Brenda,

    I think you meant multi-step forms. Sorry, but we do not have such a feature currently.

    In order to email all fields to Admin email. You can use smart tag {{all_fields}}. Or selectively add the smart tag as {{<Field Name>}}.
    You can have a look at our documentation on smart tags.

    Smart Tags

    Thanks & Regards,
    WPEverest Support Team.

    in reply to: User Registration form not responding. #20253

    rumesh38
    Moderator

    Hi Brenda,

    Can you elaborate on what was your issue? We were unable to understand your problem.

    Thanks & Regards,
    WPEverest Support Team.

    in reply to: Additional tabs on account page #20252

    rumesh38
    Moderator

    Hi there,

    It’s possible that your permalink needs to be updated. Please go to Dashboard > Settings > Permalinks and just Save Changes without changing anything.

    Hope this helps!

    Thanks & Regards,
    WPEverest Support Team.

    in reply to: User login option "Per form" #19970

    rumesh38
    Moderator

    Hi Josh,

    There is no option to select a different login option for the registration form. But there is a way around for your case if you are comfortable using the code. You can add the following code in the function.php file of your theme to approve users registered through the specific form.

    function ur_set_user_status( $valid_form_data, $form_id, $user_id ) {
    
    	$user_manager = new UR_Admin_User_Manager( $user_id );
    
    	$alert_user_email = false; // Set true to send email to user for approval.
    
    	if ( in_array( $form_id, array( '<Your form ID to be approved>' ) ) ) { // [user_registration_form id = "<Your form ID>"]
    		$user_manager->save_status( UR_Admin_User_Manager::APPROVED, $alert_user_email );
    		wp_clear_auth_cookie();
    		wp_set_auth_cookie( $user_id );
    	}
    }
    add_action( 'user_registration_after_register_user_action', 'ur_set_user_status', 20, 3 );
    
    function ur_user_register_status( $success_params, $valid_form_data, $form_id, $user_id ) {
    	if ( in_array( $form_id, array( '<Your form ID to be approved>' ) ) ) { // [user_registration_form id = "<Your form ID>"]
    		$success_params['auto_login'] = true;
    	}
    
    	return $success_params;
    }
    add_filter( 'user_registration_success_params', 'ur_user_register_status', 10, 4 );
    

    Hope this help!

    Thanks & Regards,
    WPEverest Support Team.

    in reply to: Recover password mail from wrong email #19967

    rumesh38
    Moderator

    Hi Philipp,

    Sorry for the delay, but we would like to let you know that this issue has been fixed. And we are ready to release a new update.
    Hope you will co-operate with us!

    Thanks & Regards,
    WPEverest Support Team.

    in reply to: Redirect after Logout not working #19773

    rumesh38
    Moderator

    Hi Philipp,

    Sorry, but it’s not possible to redirect after logout. There is no such feature in our plugin.

    Thanks & Regards,
    WPEverest Support Team.

    in reply to: User Registration Data Update doesn't work #19610

    rumesh38
    Moderator

    Hi there,

    Please try re-installing the plugin. Hope that might solve your problem.

    Thanks & Regards,
    WPEverest Support Team.

Viewing 15 posts - 1 through 15 (of 96 total)