Social Connect – Facebook set up

Home Forums User Registration Social Connect – Facebook set up

This topic contains 6 replies, has 4 voices, and was last updated by  sanjeev3 1 year, 1 month ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #3559

    Rodrigo Montiel
    Participant

    Hello,

    I’m trying to set up Facebook Log in and I’ve set the urls for valid OAuth in my facebook configuration like so:
    https://mydomain.net, https://mydomain.net/wp-login.php?user_registration_social_login=facebook&ursc_action=login

    When I press Login button from my site I get redirected to the following url
    https://www.facebook.com/v2.10/dialog/oauth?client_id=11110112151490453&state=a43987c06a39ccf3dcd192251c6b4db4&response_type=code&sdk=php-sdk-5.5.0&redirect_uri=https%3A%2F%2Fmydomain.net%2Fwp-login.php%3Fuser_registration_social_login%3Dfacebook&scope=email%2Cpublic_profile

    And I see the following message: “Not Logged In: You are not logged in. Please login and try again.”

    If I then first log in to facebook and then try to hit the Login button from my site I get redirected to facebook and I get the following message:

    “Warning URL Blocked: This redirect failed because the redirect URI is not whitelisted in the app’s Client OAuth Settings. Make sure Client and Web OAuth Login are on and add all your app domains as Valid OAuth Redirect URIs.”

    Am I setting the urls for valid OAuth correctly?

    Thank you in advance

    #3563

    sanjeev3
    Member

    Hello,

    The error indicates the redirect url is not setup correctly. Please follow this documentation and let us know https://docs.wpeverest.com/docs/user-registration/user-registration-add-ons/user-registration-social-connect/. Also, contact us from here help@wpeverest.com, we may need further more information to dig into the issue.

    Thanks!

    #4024

    sanjeev3
    Member

    Hey Montiel,

    Have you tried opening up the wp-admin dashboard and tried? Also, the URL Blocked: This redirect failed because the redirect URI is not whitelisted in the app’s Client OAuth Settings. error is due to the invalid OAuth Redirect URIs. Make sure you have the https://example.com/wp-login.php?user_registration_social_login=facebook like Redirect URIs. Screenshot: https://ibb.co/nOAjsK

    Hope this helps! Also, you can add the facebook login button in user registration login pages as well and disable wp admin dashboard, but to note if only the user from using facebook login is not already registered, the plugin needs to redirect to the wp admin dashboard, which in your case is failing because you have disabled/hidden the wp-admin dashboard.

    Regards,
    WPEverest Support

    #4028

    jean-simon tremblay
    Participant

    I did those step and now I get this problem:
    ERROR: Facebook connection failed. Please contact website admin.

    So the OAuth is working fine now.. but this error I dont get why its there

    #4282

    Tarik Budak
    Participant

    I have same issue

    #4372

    sanjeev3
    Member

    Hello,

    We are looking into the possbile solutions of the issue. We will get back to you guys soon once fixed. Please stay updated!

    All appologies for the inconvenience!

    Regards,
    WPEverest Support

    #4582

    sanjeev3
    Member

    Hello,

    The issue has been fixed and the new version update for user registration social connect is now available. Also, You can now register socially connected user with user registration form too without redirecting to wp-login or wp-admin. Make sure you have callback url like: https://example.com/login?user_registration_social_login=facebook&ursc_action=login where login is the login page slug created with shortcode [user_registration_login] in your social media app. If you like to set the social login on wp-login.php, the callback url should be like: https://example.com/wp-login.php?user_registration_social_login=facebook&ursc_action=login

    let us know if you are still facing the issues.

    Regards,
    WPEverest Support

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.