Problems with CheckBox fields with Version 1.1.6 upgrade.

Home Forums User Registration Problems with CheckBox fields with Version 1.1.6 upgrade.

This topic contains 12 replies, has 2 voices, and was last updated by  sanjeev3 1 year, 6 months ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #1115

    Aldersoft
    Participant

    Hi … I just installed version 1.1.6 from 1.1.5.
    Under 1.1.5 my checkbox field worked just fine in terms of formatting ie. checkbox to the right of the field. IE. Show Me Publicly* [ ]
    [ ]
    Now under version 1.1.6, the checkbox appears on top of the last letter of the field. IE. Show Me Publicly*
    Looks like a CSS issue. Note I have not changed anything CSS wise. I am using Theme XMag.
    You still have access to my site http://Aldersoft.DynDNS.org/the-msa-devl.
    To see version 1.1.5 look at http://The_MSA.CA goto menu item Membership then Registration
    To see version 1.1.6 look at http://Aldersoft.DynDNS.org/the-msa-devl –> menu Membership –> Registration.

    #1116

    Aldersoft
    Participant

    On another note. The Note/Comment field for the checkbox does not appear in either version.

    #1117

    sanjeev3
    Member

    Hello Aldersoft,

    Checkbox formatting is fine in default themes and most of the custom themes too. However, it does mismatches with Xmag, Please add the additional css in your customizer.

    #ur-frontend-form blockquote, #ur-frontend-form input, #ur-frontend-form select {
      width: auto;
    }

    Regarding the second question, what comment field for checkbox are you referring to? Please elaborate a bit.

    Regards,
    WPEverest Support

    #1125

    Aldersoft
    Participant

    I added your CSS mod to the Xmag’s Additional CSS and all it did was move the check to the far left of the field instead of the far right where I want it. Field definition is as follows:
    ——————–
    General Settings
    Label
    Show Me Publicly

    Field Name
    show_publicly
    Placeholder

    Placeholder
    Required

    Advance Settings
    Custom Class
    Custom Class

    Choices
    Please input your text here to create the checkbox list like:
    Checkbox 1,
    Checkbox 2,
    Checkbox 3
    ——————————————–

    Note I have tried putting text into Choices but it does not display, which was my second question.
    Also my colours went to white on white for the background and data boxes. When clicked the boxes turn light grey.

    #1126

    Aldersoft
    Participant

    I did some experimentation and I believe I see the problem.

    Choices are used to assign the value to the checkbox variable.
    Your example is misleading when it says:

    Please input your text here to create the checkbox list like:
    Checkbox 1,
    Checkbox 2,
    Checkbox 3

    Essentially what you are saying is that you can input a multi-value list.
    I see what you are doing now, but some problems: (BTW using this it formats correctly)

    1. The example implies that if you check “Checkbox 1” you would get the value 1, where as in actual fact you get the value “Checkbox 1″.
    I am assuming that field[] in an input statement implies an array.

    2. Generally I have only seen check boxes used for Boolean values, IE. TRUE if checked or FALSE if not. This is what I actually want.
    Alternately, I should be able to separate the value and the description: eg. <input type=”checkbox” name=”variable” value=”1″ description>

    Any thoughts ?

    #1127

    sanjeev3
    Member

    The checkbox formatting is how it is. Generally, the checkbox is at left and the label at the right. If you require anything else please modify with additional CSS.

    And yes, the choices are for multiple checkboxes, that is what you misunderstood or we fail to explain. And the value is is boolean for single checkbox and similar to the format you mentioned.
    <input type=”checkbox” name=”variable” value=”1″ description>

    For the questions regarding white for white background and boxes turning to light grey, please adjust with additional CSS. Or provide your site link (which you mentioned above are broken) so we can look into it and provide you with CSS.

    The single and multiple checkboxes should be like: https://ibb.co/iY5AHR

    #1129

    Aldersoft
    Participant

    RE: “Or provide your site link (which you mentioned above are broken) so we can look into it and provide you with CSS.”

    My links are just fine … see start of messages which say:
    You still have access to my site http://Aldersoft.DynDNS.org/the-msa-devl.
    To see version 1.1.5 look at http://The_MSA.CA goto menu item Membership then Registration
    To see version 1.1.6 look at http://Aldersoft.DynDNS.org/the-msa-devl –> menu Membership –> Registration.
    Note these links do not require a sign in.

    I do agree, that will work for me https://ibb.co/iY5AHR. But please see the difference between 1.1.5 and 1.1.6. I just want the 1.1.5 format back again or to the left, but not overlapping the character.

    Reviewing the code in user_registration/includes/forms/views/admin/admin-checkbox.php, I understand about choices<1.
    Ideally it would work best if it were consistent with the other fields and be below the variable name.

    #1130

    Aldersoft
    Participant

    If you prefer the page_id links:
    The version 1.1.6 is http://aldersoft.dyndns.org/the-msa-devl/?page_id=497
    The version 1.1.5 is http://the-msa.ca/the-msa-prod/?page_id=366

    #1216

    Aldersoft
    Participant

    Hi … I am still waiting for a response on the two comments above. If I can get the checkbox to at least line up the same way it did under 1.1.5 that would solve my problem. I have tried playing around with float to no avail. Please look at the two sample in the comment above to see the difference.

    #1218

    sanjeev3
    Member

    Hello, Additional CSS is the only preferred way because the problem is with that particular theme. And could provide you with additional CSS but the links provided are not accessible here please. Or you can show the screenshots of the two different versions checkbox so that you could help you. Thanks!

    #1381

    Aldersoft
    Participant

    So did whatever you changed in 1.2.0 address my checkbox issue ?

    BTW. I gave up on checkbox and went with radio buttons for yes and no instead.
    The values were rather strange 0__Yes and 1__No. Either give me position or preferably value but both is crazy.
    I see in the release notes for 1.2.0 you have done something in this area, but you don’t provide an explanation.
    Currently I am coding for:
    $list_user_publicly = FALSE;
    if ( isset( $user_info->user_registration_show_publicly ) ) {
    if ( $user_info->user_registration_show_publicly == “0__Yes” ) {
    $list_user_publicly = TRUE;
    }
    }
    Do I need to change ? My user_meta data ?
    What are you doing now ?

    #1382

    Aldersoft
    Participant

    Ok … I bit the bullet and updated on my test site.
    I had to delete an existing user before I received the prompt to run the Database update. Probably just a WP thing.
    The update worked perfectly and set the ‘0__Yes’s to ‘Yes’ … excellent.
    I of course had to do a manual syncfield to get sync’ed fields updated. (Syncfield plugin)

    I really love your email message editing. I had copied my custom ones across to includes/admin/settings/emails and
    they got picked up. I edited them and they went somewhere. I suspect the database.

    Great Work guys !!! I am a happy camper again.

    Just for curiousity sake, what is the story on the checkbox ?

    #1383

    sanjeev3
    Member

    Hello, as replied earlier the checkbox issue seems to be in only one particular theme so additional CSS is only preferred way. And the links provided are not accessible here. Or if only you can show the screenshots of the two different versions checkbox and your preferred design, we may find a way to help you.

    Thanks!

Viewing 13 posts - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.