Conditional field not saving its condition properly

Home Forums User Registration Conditional field not saving its condition properly

This topic contains 10 replies, has 2 voices, and was last updated by  sanjeev3 1 year ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #4727

    Mike Berg
    Participant

    I’ve got a text area that I want to have show up only if a certain checkbox is selected in the previous field.

    layout of how it's set up

    Here’s how I set up the condition for the text area field:

    how it's set

    After I save the form, the last popup gets reset:

    how it is after saving

    Is there a way to get this to save correctly? Thanks!

    Using:
    User Registration v1.4.7
    User Registration Conditional Logic v1.0.2
    WP v4.9.8

    #4729

    sanjeev3
    Member

    Hello Mike Berg,

    Looks like we are having issues with the spaces and enter. You can assign the checkboxes values without entering space or enter in options section.

    Screenshot: https://ibb.co/kxnrRz

    If you are still getting issues, we will get back to you.

    However, we will look into this spacing issue too.

    Regards,
    WPEverest Support

    #4800

    Mike Berg
    Participant

    Thanks! I’ve tried removing the spaces and line breaks so that it’s all on one line. The conditional popup is now saving correctly, but when you scroll down to Workshop Format select the checkbox for participants help build/make something, the field does not appear.

    The field with the conditional rule is a textarea called Would your workshop involve building or installing something on the farm (ie herb spiral, guest chicken coop, mushroom laying yard)?, and it should appear directly below the Workshop Format set of checkboxes.

    -Mike

    #4807

    sanjeev3
    Member

    Hello Mike,

    Can you please share your site url with registration form to look into the issue?

    Regards,
    WPEverest Support

    #4969

    Mike Berg
    Participant

    Oops, sorry; forgot to include that. I meant to! https://homesteaderfest.ca/registration/workshop-leader/

    #5001

    sanjeev3
    Member

    Hello Mike,

    Thanks. We will fix this issue soon. Please stay updated!

    Regards,
    WPEverest Support

    #5030

    sanjeev3
    Member

    Hello again,

    The new version 1.4.9 of user registration is now available and should fix this issue. Please update the plugin and let me know if you are still having issue.

    Thanks,

    #5236

    Mike Berg
    Participant

    Here’s what happened when I went to update the plugins:

    Plugin update error

    #5255

    sanjeev3
    Member

    Hello Mike,

    This might be due to the files and folder permission issue set by the server. Please download the add-on manually from my-account section and let us know if you are still having issues.

    Regards,
    WPEverest Support

    #5355

    Mike Berg
    Participant

    Weird; I refreshed my plugins page and then it showed all the plugins as being updated correctly! In any case, the conditional field is working correctly now.

    One final question:
    Can I make that field a required field, but ONLY if it’s visible?

    Thanks!

    #5395

    sanjeev3
    Member

    Hello Mike,

    Yes, if the field is required and is hidden by conditional logic it will bypass the require. Do you have any issues on getting it work?

    Thanks!

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.