Address Editing under My Account page is not working

Home Forums User Registration Address Editing under My Account page is not working

This topic contains 10 replies, has 2 voices, and was last updated by  rumesh38 3 months ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #16930

    Cheng-En Yang
    Participant

    Hello Support team,
    I’m using [user_registration_my_account] to display all the information.
    However, the address editing function under My Account > Address is not working.
    I can see the editing page and edit it, but when I click save, it direct to a 404 page.
    The address is like this: https://www.example.com/edit-address/

    Not sure if this information would help:
    I removed “My Account” page from WooCommerce>Setting>Advanced>Page Setup>My Account Page. Because if I assign the page here, the original my account page built by WooCommerce will show up instead of the one built by you.

    #16959

    rumesh38
    Moderator

    Hi there,

    It seems that problem was you deleting the WooCommerce’s My Account page. You have to select Our My Account page in WooCommerce>Setting>Advanced>Page Setup>My Account Page.
    Hope this might solve the problem.

    Thanks & Regards,
    WPEverest Support Team.

    #17062

    Cheng-En Yang
    Participant

    Hi,

    Like I’ve already mentioned, if I set up the My Account Page for WooCommerce, the original my account page built by WooCommerce will show up instead of the one built by you.
    Could you please help on this? Thanks!

    #17301

    rumesh38
    Moderator

    Hi there,

    Can you provide us your site URL? So that we can look into it.

    Thanks & Regards,
    WPEverest Support Team.

    #17302

    Cheng-En Yang
    Participant

    here you go:
    http://www.easycookasia.de

    Thanks!

    #17328

    rumesh38
    Moderator

    Hi there,

    Please contact us at help@wpeverest.com. We might need further access to debug the issue.

    Thanks & Regards,
    WPEverest Support Team.

    #17500

    rumesh38
    Moderator

    Hi there,

    It seems that your permalink was not updated. You can simply go to Settings > Permalink and just save without change anything. It will fix your problem.

    Thanks & Regards,
    WPEverest Support Team.

    #17504

    Cheng-En Yang
    Participant

    Hi,

    Thanks for the information.
    I did it following your instruction, but it is still not fixed.
    Could you please take a look again? Thank you!

    #17631

    rumesh38
    Moderator

    Hi there,

    It seems to be working for me. I have created an account and try editing address. It successfully updated. There is no such a 404 error you mentioned. I will be sending screenshot through email.

    Thanks & Regards,
    WPEverest Support Team.

    #17635

    Cheng-En Yang
    Participant

    Hi,

    I checked the screenshots. It seems everything’s fine but this account page is the WooCommerce one, not from USER REGISTRATION plugin.

    There are two reasons why I think this is the WooCommerce one:

    1. When I tried to use the USER REGISTRATION plugin to change the layout to “Horizontal” or “Vertical”, nothing happened.

    2. When I removed the “My Account” page from WooCommerce setting, the correct My Account page showed up, and the layout change can work.

    However, if I did No.2, the address editing function wouldn’t work as I explained in the first post.

    Could you please take a deeper look into this issue? Thank you!

    #17681

    rumesh38
    Moderator

    Hi Cheng,

    It seems “WooCommerce Page Builder” has been replacing the page content with WooCommerce’s Account page. After I seleted account page in “My Account Page Template” in WooCommerce > WooCommerce Page Builder > Accounts Tab it solve the issue.

    Thanks & Regards,
    WPEverest Support Team.

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.